Game Design, Programming and running a one-man games business…

What would Jack Thompson think?

When I create particle emitters they normally have a parent object, but some, such as missiles being shot down and exploding, do not and are ‘orphaned emitters’.

These die out, but if you quit mid battle, some orphans are left. If you then start a new battle, you see the smoke clouds from the previous one for a few seconds.

So I need to clear them and fix that. So I am writing a new function called

KillAllOrphans()

What would Jack Thompson or the tabloid press think?


13 thoughts on What would Jack Thompson think?

  1. Just in case, you might want to rename the function to something like “LetNaturalSelectionHaveItsWay()” or “GiveParticlesToA3YearOld()”, or something like “DoWithOrphanedParticlesWhatIWouldDoToJackThompsonAndTheTabloidPress()”.

  2. Kernighan and Ritchie would say “Just write function-names all lower case.”. ;)

  3. K&R have been surpassed by ANSI, you know. ;-)

    Though naming conventions are not part of any standards. ;-)

  4. copy-paste from my code:

    void KillChildren(BOOL bDelete = TRUE); // be cruel by default..

  5. I think I had a KillAllChildren() in Venture the Void somewhere. Why stop at orphans?

    Also, my personal favorite inbuilt function call, which I’ve never forgotten was from QuickBASIC like 15 years ago. For some reason, QuickBASIC had support for the light pen (whatever the heck that is) but not the mouse. You needed to be able to tell if it was up, or not. So the function was, quite logically, called:

    PENISUP()

    Arousing!

  6. I love coincidental naming puns…
    In a dinosaur sim I worked on there were certain actions that a dino could perform that were linked to particular key presses and releases. Therefor I abstracted this out into methods that looked like this…

    Dino::makeCharge()
    Dino::breakCharge()
    Dino::makeEat()
    Dino::breakEat()
    Dino::makeDrink()
    Dino::breakDrink()

    Dino::makePoop()

  7. Reminds me of one my functions I’ve got in my flash project. . .
    “private function killKids()”

    Seems I’m taking this murdering children thing a step a head of you and getting rid of them all.

Comments are currently closed.