Page 1 of 1

oops

Posted: Mon May 26, 2008 4:02 am
by saywhatman
I tried to mod my Votertypes.csv file, and tried adjusting the percentage of each group. But when I opened up Democracy 1, and select a country, the game crashes and says that votertypes.csv is the problem. (Crash Reporter on a mac). How can I fix this?
here is part of the log file:
Date/Time: 2008-05-25 21:21:07.055 -0700
OS Version: 10.4.11 (Build 8S2167)
Report Version: 4

Command: Democracy
Path: /Applications/Democracy.app/Contents/MacOS/Democracy
Parent: WindowServer [65]

Version: ??? (1.0)

PID: 13561
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0x6c6c6248

Thread 0 Crashed:
0 com.redmarble.Democracy 0x0009abe5 std::vector<VoteGroupMod, std::allocator<VoteGroupMod> >::_M_insert_aux(__gnu_cxx::__normal_iterator<VoteGroupMod*, std::vector<VoteGroupMod, std::allocator<VoteGroupMod> > >, VoteGroupMod const&) + 1087
1 com.redmarble.Democracy 0x000992ce std::list<Voter*, std::allocator<Voter*> >::remove(Voter* const&) + 10720
2 com.redmarble.Democracy 0x00099755 std::list<Voter*, std::allocator<Voter*> >::remove(Voter* const&) + 11879

Re: oops

Posted: Wed May 28, 2008 7:34 am
by cliffski
sounds like a typo (missing comma?) at the end of one of the lines, where the modifiers that tell you what group is mixing with what other group has been changed.